<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
Dynamically Changing Field Names in Okta SSO Login Page
Single Sign-On
Okta Identity Engine
Overview

Users trying to automate Okta SSO login through their applications or scripts may face issues when the field names on the login page keep changing dynamically. This can lead to automation tools failing to find the correct fields on the page, preventing successful login. This article provides steps to address this issue.

Applies To
  • Okta Single Sign-On (SSO) login page
Cause
Okta periodically changes the field names on their SSO login page to prevent cyber attacks. This can lead to automation tools that rely on static field names failing to find the correct fields on the page.
Solution

The IDs for the input fields are not expected to be static and may change from one release or widget version to another. Therefore, automation tools using the sign-in widget's input fields are recommended to use field names or types instead of IDs, as they are less likely to change.
 

To find the field name or type:
 

  1. Inspect the login page using the browser's developer tools.

  2. Find the field name or type of the input field that corresponds to the data that needs to be filled in.

  3. Update the script or application to pass the data to the input field based on the field name or type instead of the ID.


This solution should work for any application that uses Okta's App Embed Link for SSO login.

Loading
Dynamically Changing Field Names in Okta SSO Login Page