Dropbox Business Provisioning "Error while creating user: Errors during execution: Error executing createNewUser: team_license_limit. Error Code: null"
Okta Integration Network
Overview

Dropbox Business provisioning flow fails with the following error visible in the Okta dashboard:

Automatic provisioning of user <username> to app Dropbox Business failed: Error while creating user <username>: Errors during execution: Error executing createNewUser: team_license_limit. Error Code: null
 

Error Message

Applies To
  • Dropbox Business
  • Provisioning
  • Error
Cause
There are enough licenses available on the Dropbox Business side. This error usually appears when the Dropbox Business app data is not updated in Okta and needs to be refreshed.
Solution

Use one of the following methods to refresh application data:

Method 1

Go to the Okta Admin Console, then navigate to Applications Applications tab and click More to select Refresh Application Data (note that this will trigger an import of application data for all applications configured with Provisioning):
Refresh Application Data option 

 

Method 2

Re-authenticate API credentials that are used for provisioning to/from Dropbox Business, which will cause the download and updating of application data into Okta (this will only refresh the application data for Dropbox Business):

  1. Go to Okta admin console and navigate to Applications > Applications > Dropbox Business > Provisioning > Integration > click the Edit button.

  2. Click Re-authenticate with Dropbox Business.

  3. In the new Dropbox - API Request Authorization - Sign in window, enter the correct email and password and click Sign in.

    Dropbox - API Request Authorization - Sign in window  

  4. Back on the Provisioning page in Okta, a message confirming successful authentication will be displayed. Click Save.

  5. Afterward, attempt the user provisioning again. Go to Okta Admin Console and navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks

    Tasks 

  6. After identifying the failed task for the user that should be retried, click on Retry Selected.

  7. If the issue still persists, please contact Dropbox Business support for more details and steps on how to resolve this error.

Related References

 

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