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Device Trust SAML App Showing "App Access Locked" Error

Okta Classic Engine
Devices and Mobility

Overview

This article provides details on how to verify what caused the error below when accessing a SAML app with Device Trust enabled.

 App Access Locked


App access locked 

Applies To

  • Okta Classic Engine
  • Device Trust

Cause

The Device Trust certificate was revoked or is no longer valid.

Solution

For Okta Administrators, the solution is to re-enroll the device or force-enroll the certificate by running the Okta Device Registration Task Script.

If a user attempts to access an app from the Okta Dashboard and receives this message, please contact your local Okta Administrator to resolve the issue.

 

NOTE: Device Trust for Jamf Pro managed macOS devices is now end-of-life due to the deprecation of the JAMF Classic API.

For more information: Okta Device Trust for Jamf Pro managed macOS devices - End of Life October 2024.

 

 

Related References

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Okta Support - Device Trust SAML App Showing "App Access Locked" Error