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Desktop Single Sign On Fails on Windows Computer
Okta Classic Engine
Okta Identity Engine
Administration
Directories
Overview
Desktop Single Sign-On fails and redirects to the Okta login page on a Windows computer.
Applies To
  • Desktop Single Sign-On
  • Okta Classic Engine
Cause
Browsers are not configured for Desktop SSO
Solution

Test IWA authentication from the client machine by accessing https://<myIWA server>/IWA/authenticated.aspx to ensure there is no prompt for Windows credentials.

If prompted for Windows credentials, follow the below steps on the Windows machine to add the IWA server URL as a Local Intranet Site:

  1. On the Windows Control Panel, select Network and Internet > Internet Options > Security > Local intranet > Sites > Advanced.

  2. In the Add this website to the zone field, enter:

    1. https://hostname.companyname.com or http://hostname.companyname.com and

    2. https://<subdomain>.okta.com  or https://<subdomain>.okta-emea.com  or https://<subdomain>.oktapreview.com  as appropriate.
      NOTE: Replace the above URLs with the respective IWA server URL and Okta org URLs appropriately.

  3. Click Add.

  4. Click OK twice to close Internet Options.

    Internet Options configuration screen

Related References

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Desktop Single Sign On Fails on Windows Computer