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Datadog SAML Certificate Activation Error "Unable to activate key"
Okta Integration Network
Single Sign-On
Overview

After generating a new Security Assertion Markup Language (SAML) certificate for the Datadog application, when trying to activate it, an error appears in the Okta dashboard:

Unable to activate key

Error Message   

 

Also, when checking the network trace when this error appears, the following can be seen:

{"errorCode":"E0000039","errorSummary":"Operation on application settings failed.","errorLink":"E0000039","errorId":"oae7Tp6zo15T8i0rVt-h9WLRQ","errorCauses":[{"errorSummary":"environment: The field cannot be left blank"}]}

 

Applies To
  • Datadog
  • SAML
  • Application Certificate
  • Error
Cause
Most of the time, the SAML certificate fails to generate when there was an update done to the application in the past. 
Solution
This problem can be solved by creating a new Datadog integration.
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Datadog SAML Certificate Activation Error "Unable to activate key"