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Databricks Provisioning Error Reported by Remote Server "RESOURCE_ALREADY_EXISTS: A user with email or username in different cases already exist in the account"

Okta Integration Network

Overview

Databricks provisioning flow fails with the following error visible in the Okta dashboard:

An error occurred while assigning this app.
Automatic provisioning of user <<UserName>> to app Databricks failed: Error while creating user <user>: Internal Server Error. Errors reported by remote server: RESOURCE_ALREADY_EXISTS: A user with email <email> or username <username> in different cases already exists in the account

 

Applies To

  • Databricks
  • Provisioning
  • Error

Cause

The user with the same email address or the same username in different capitalization already exists in the Databricks account.

Solution

  1. Resolve the RESOURCE_ALREADY_EXISTS conflict by using one of the two options mentioned below:
    • Option 1: Deleting the existing user with the conflicting email address or username on the Databricks side.
    • Option 2: Changing the email address of the user who needs to be assigned to the Databricks app in Okta.
  2. After confirming that the conflict has been resolved, attempt user provisioning again. Go to the Okta Admin Console and navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks.

Tasks 
 

  1. After identifying the failed task for the user that should be retried, click on Retry Selected.

NOTE: If the issue persists, please contact Databricks support for more details and steps to resolve this error.

 

Related References

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Okta Support - Databricks Provisioning Error Reported by Remote Server "RESOURCE_ALREADY_EXISTS: A user with email or username in different cases already exist in the account"