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Cisco Webex Provisioning Error The Request Requires a Valid Access Token Set in the Authorization Request Header

Okta Integration Network

Overview

Cisco Webex provisioning flow fails with the following error visible in the Okta dashboard:

Automatic provisioning of user <user> to app Cisco Webex failed: Error while verifying if user <user> exists: Unauthorized. Errors reported by remote server: The request requires a valid access token set in the Authorization request header
 

Error Message

Applies To

  • Cisco Webex
  • Provisioning
  • Error

Cause

The API token used to create the API connection is invalid.

Solution

  1. In a browser tab, go to the customer view in https://admin.webex.com, click on the organization's name, and then next to Company Information, copy the Organization ID. Record the organization ID (copy and paste it into a text file).
  2. Go to Okta Admin Console and navigate to Applications > Applications > Cisco Webex > Provisioning > Integration > Edit.
  3. Enter the ID value copied in Step 1 in the Organization ID field.
  4. Follow these steps to get the bearer token value for the Secret Token.
  5. Paste the bearer token in step 4 into the API Token field.
  6. Click Test API Credentials, verify the successful connection, and click Save.
  7. Attempt the failed tasks again. Navigate to Dashboard > Tasks. Any failed assignments should appear under Tasks.

Tasks

  1. After locating the failed task for the user that should be retried, click on Retry Selected.

Related References

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Okta Support - Cisco Webex Provisioning Error The Request Requires a Valid Access Token Set in the Authorization Request Header