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Unable to Set "Session expires after" to a Specific Value within a Sign-on Policy
Administration
Okta Classic Engine
Okta Identity Engine
Overview

While attempting to set a specific value for the "Session expires after" parameter, there might be a warning displayed on the interface stating: 

 

Value must be <value>.



Set Value for "Session expires after" Parameter 

 

This article explains the cause of this warning and how to avoid it.

 

Applies To
  • Security
  • Sign-on policy
Cause
Creating a sign-on rule through API will offer the option of setting the maximum session lifetime and maximum idle time. However, the Administrator UI will only display the maximum idle time field and its corresponding value. If the maximum idle time has been set to a greater value than the maximum session lifetime, the UI will show the error message seen in the screenshot.
Solution

Using API, set the maxSessionIdleMinutes value to be lower than maxSessionLifetimeMinutes.


Related References

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Unable to Set "Session expires after" to a Specific Value within a Sign-on Policy