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BambooHR Error "Failure: API key not provided or invalid"
Okta Integration Network
Overview

This article addresses the error that appears during BambooHR Sync:


Failure: API key not provided or invalid

 

Applies To
  • BambooHR
  • Profile Sync
  • User Import
  • Lifecycle Management
Cause
This is due to the API Key from BambooHR expiring or becoming invalid.
Solution
  1. Log in to BambooHR as an administrator.
NOTE: Bamboo recommends using a service account to generate the API Key, as opposed to using an individual administrator's credentials.
  1. Select Account Settings in the upper right corner, then select API Keys.
Bamboo settings
  1. Select Add a new key, or use an existing one (if there is one, see the list of My API Keys).

API Keys

  1. Make a copy of the Key to enter in Okta later in this procedure.
  2. Once the key has been generated, please navigate to the BambooHR Application within Okta and update it under the Provisioning tab.


Related References

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BambooHR Error "Failure: API key not provided or invalid"