Workday Provisioning Error "You cannot initiate this action because there are other pending or completed actions for the worker that conflict with this one"
Okta Classic Engine
Okta Identity Engine
Okta Integration Network
Overview

Workday's provisioning flow fails with the following error visible in the Okta dashboard:

Automatic profile push of user to app Workday failed: Unable to update personal info for Workday employee: Validation error occurred. You cannot initiate this action because there are other pending or completed actions for the worker that conflict with this one.

Applies To
  • Workday
  • Provisioning
  • Attribute Mappings
  • Error
Cause

The issue occurs most commonly when the user's profile in Workday has future-dated actions, typically as part of the pre-start interval as described in this Workday Provisioning document.


NOTE: Setting a non-zero Pre-Start Interval will import future-dated Workday user updates ahead of time by the number of days specified. For example, a Workday provisioning group membership change that is scheduled with an effective date 2 days in the future will be reflected in Okta immediately on the next import if the Pre-Start Interval value is set to 3.


Workday throws the error because the attribute that is trying to be mapped from Okta is "pending," Workday does not allow the attribute to be updated until after the future-dated action has occurred.

Solution
  1. Temporarily remove any future-dated actions in the user's Workday profile.
  2. Re-attempt the profile update push from Okta.
  3. Once this is complete, re-add the future-dated actions in Workday.

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