Atlassian Cloud Single Sign-On (SSO) Error "There appears to be an issue with the destination URL used for your SAML single sign-on configuration"
Single Sign-On
Okta Integration Network
Okta Classic Engine
Okta Identity Engine
Overview

Atlassian Cloud OIN app Single Sign-On (SSO) flow fails with the following error visible on the Atlassian landing page: 

Hmm... we're having trouble logging you in. You'll need to talk to your Organisation admin - tell them we sent you, and that there appears to be an issue with the destination URL used for your SAML single sign-on configuration.

 

Error Message  

 

Applies To
  • Atlassian Cloud
  • Single Sign-On (SSO)
  • Error
Cause

The Unique ID in Okta is configured to be the same as the SP Entity ID.

Solution
  1. In Atlassian, locate the SP Entity ID in the View setup instructions and copy everything after https://<auth>.atlassian.com/saml/.
  • For example, if the SP Entity ID is https://<auth>.atlassian.com/saml/a1b2c3d4, the Unique ID is a1b2c3d4.
  1. Update the Unique ID field in the Okta Atlassian Cloud Application by going to the Sign on tab > Settings > Edit Advanced Sign-on Settings Settings > Unique ID.

Advanced Sign-on Settings

 

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