Okta Application Usernames Do Not Update Automatically
Last Updated:
Overview
Okta does not update application usernames automatically when the Application Username Format uses the Create and Update setting because the configuration lacks specific conditions. Enable provisioning, configure a valid custom format, or map multiple attributes as needed to resolve the issue.
Applies To
- Okta Identity Engine (OIE)
- Okta Classic Engine
- Mappings
- Okta Attributes
- Application Username
Cause
Okta only updates the application username automatically if the configuration meets specific conditions.
Solution
Specific Conditions Must Exist for Okta to Update Application Usernames Automatically
Satisfy one of the following conditions to prompt Okta to update the application username automatically.
- The application has provisioning enabled.
- The Application Username format uses the Custom setting and avoids deprecated expressions or non-working expressions.
NOTE: Use the corresponding mappings for the required username format.
Review the following examples of mappings that achieve specific username formats.
-
- Okta Username (
user.login). - Okta Username Prefix (
String.substringBefore(user.login, "@")). - Email (
user.email). - Email Prefix (
String.substringBefore(user.email, "@")) . - Any unique Okta attribute can be referenced on the username by using
user.variableName(for example,user.title, user.employeeID, etc.).
- Okta Username (
- The application contains more than one attribute that maps as Create and Update from Okta to the application.
What steps manually update the application username?
If the configuration lacks the required conditions, Okta does not update the application username automatically. Update the application username manually for all users who possess an application assignment by navigating to the application settings and initiating the update.
- Choose the Sign On tab of the application.
- Select the Update Now button.
