<iframe src="https://www.googletagmanager.com/ns.html?id=GTM-M74D8PB" height="0" width="0" style="display:none;visibility:hidden">
Loading
Skip to NavigationSkip to Main Content
Application Usernames Are Not Being Updated Automatically
Lifecycle Management
Okta Classic Engine
Okta Identity Engine
Overview
Application usernames are not being updated automatically when Application Username Format is set to Create and Update.
Applies To
  • Mappings
  • Okta Attributes
  • Application Username
Cause
Okta only updates the application username if certain conditions are met. These are detailed below.
Solution

In order to have the application username update automatically, ensure that one of the following conditions is met:

  1. Provisioning is enabled.
  2. The Application Username format is set to Custom and is not using deprecated expressions or non-working expressions.  

NOTE: Use the corresponding mappings for the required username format. Examples of this are listed below: 

      1. Okta Username ( user.login ).
      2. Okta Username Prefix ( String.substringBefore(user.login, "@") ).
      3. Email ( user.email ).
      4. Email Prefix ( String.substringBefore(user.email, "@") ) .
      5. Any unique Okta attribute can be referenced on the username by using user.variableName (for example, user.title, user.employeeID, etc.).

Credentials Details screen showing the examples

 

  1. The application has more than one attribute mapped as Create and Update from Okta to the Application.

Custom SAML User Profile

 

If none of the conditions are satisfied, the application username will not update automatically. However, it can be updated manually by selecting the Sign On tab of the application and clicking on the Update Now button. This process will update the application username of all users assigned to the application. It is not possible to exclude users.

Credentials Details Update Now

Related References 

Loading
Application Usernames Are Not Being Updated Automatically