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Troubleshooting Agentless Desktop SSO Not Triggering Automatically
Okta Classic Engine
Directories
Okta Identity Engine
Overview

This article explains why users are not routed to the Agentless Desktop Single Sign-On (DSSO) authentication flow after enabling the setting under Delegated Authentication and completing all of the prerequisite setups in Configure Agentless Desktop Single Sign-On.

Applies To
  • Directories
  • Agentless Desktop Single Sign-On (DSSO)
  • Routing Rules
Cause
The routing rule automatically created when Agentless DSSO was initially configured has been deleted. Disabling and enabling Agentless DSSO will not recreate a new routing rule. The default rule is only created the first time the service is enabled.
Solution

Follow the video or the steps below to manually create a new Agentless DSSO Routing Rule.

  1. In the Okta Admin console, navigate to Security Identity Providers > Routing Rules.

  2. Click on Add Routing Rule.

  3. Configure the routing rule based on the Network Zones as in the screenshot below:

    Add rule 

  4. Select AgentlessDSSO from the drop-down under Use this identity provider.

  5. Click on Create Rule.

  6. Click on the Activate button on the Rule to activate it and move it to the highest priority, depending on the use case. If the rule should not be activated yet, click on Don't Activate.

Activate rule

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Troubleshooting Agentless Desktop SSO Not Triggering Automatically