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Agentless DSSO Not Working After Setting AES Encryption on Service Account
Directories
Overview
Agentless DSSO requires AES 128 and 256 be enabled on the SPN service account. If this step is missed and fixed afterwards additional steps may be needed.
Applies To
  • Directories
  • Agentless DSSO
Cause

In some cases, when the ADSSO Service Account is created and the SPN is set without the correct AES encryption settings on the service account, just correcting the AES encryption settings will not automatically resolve the issue.
 

ADSSO

Solution

If the AES is enabled on the ADSSO SPN service account that generates the Kerberos tokens and finds that the tokens are still being issued with RC4 encryption, the ADSSO SPN service account password may need to be reset manually. This is because the account password does not automatically rotate, and the current password may have been set previously when AES key generation was not supported.

Once the password is reset in Active Directory, validate the service account password under Security > Delegated Authentication > Agentless Desktop SSO in the Okta Admin Console.

Related References

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Agentless DSSO Not Working After Setting AES Encryption on Service Account