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Admin/User Getting Error as "Other user" during RDP Connection
Advanced Server Access
Privileged Access
Okta Classic Engine
Okta Identity Engine
Overview

All users (admin or non-admin) are unable to Remote Desktop Protocol (RDP) and are getting messages as "Other user".  The snapshot below is for reference: 

Other user 

Applies To
  • Okta Advanced Server Access (ASA)
  • Okta Privileged Access (OPA)
  • Windows Servers
Cause

Okta ASA uses local accounts for RDP.  A Group Policy may be denying such a user group for remote login through any of the following policies under Computer Configuration > Policies > Windows Settings > Security settings > Local policies > User Rights Assignment : 

  • Allow log-on through Remote Desktop Services
  • Deny Log on through Remote Desktop Services 
Solution

Follow the steps below to update the group policy:

  1. Open Group Policy Management on the affected Windows server.
  2. Go to Computer Configuration > Policies > Windows Settings > Security settings > Local policies > User Rights Assignment.
  3. Make sure the two policies, if configured, have the needed settings to allow users through the ASA:
    • "Deny Log on through Remote Desktop Services" should not have "Remote Desktop Users"
    • "Allow log on through Remote Desktop services" should have the same group
  4. Apply the changes and run "gpupdate /force" from the command line as administrator to update the group policy 
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Admin/User Getting Error as "Other user" during RDP Connection