AD Agent Disconnecting after Service Account Password Change
Last Updated:
Overview
After updating the password for the Active Directory (AD) service account that runs the Okta AD Agent, the agent will intermittently disconnect from Okta with the error:
Unexpected response status (407 ProxyAuthenticationRequired) for request URI - Access Denied.
Applies To
- Directories
- Active Directory
- AD Agent
- Proxy Configuration
Cause
There is a proxy server configured between the AD Agent and Okta, and the service account password was not updated in the proxy settings.
Solution
Uninstall and reinstall the Okta AD Agent, and be sure to update the Password field on the Okta AD Agent Proxy Configuration page.
