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"409 Conflict" Error when Using the Google Create Transfer Request Cards in Workflows
Workflows
Okta Classic Engine
Okta Identity Engine
Overview

When using the Google Drive connector and Google Calendar connector Create Transfer Request cards, a 409 Conflict error similar to the following may be returned:

{
  "_error": true,
  "retry_count": 0,
  "flo": 246256,
  "method": "umi3-PnGM",
  "execution": "6182a3d3-ceb8-4f53-b802-021a8bcc0fbd",
  "module": "googlecalendar.createTransferRequest",
  "kind": "HTTP Request Error",
  "statusCode": 409,
  "headers": {
    "x-xss-protection": "0",
    "content-type": "application/json; charset=UTF-8",
    "vary": "Referer",
    "x-frame-options": "SAMEORIGIN",
    "content-length": "269",
    "x-content-type-options": "nosniff",
    "server": "ESF",
    "alt-svc": "h3=\":443\"; ma=2592000,h3-29=\":443\"; ma=2592000",
    "date": "Tue, 11 Jul 2023 19:52:23 GMT"
  },
  "body": {
    "error": {
      "code": 409,
      "message": "Data transfer already in progress for the user.",
      "errors": [
        {
          "message": "Data transfer already in progress for the user.",
          "domain": "global",
          "reason": "conflict"
        }
      ]
    }
  },
  "message": "409 Conflict",
  "code": 409,
  "description": "HTTP Request Error",
  "steps": 47,
  "source": {
    "flo": "googlecalendar:1.0.200:createTransferRequest",
    "method": "6UmE8bkHo4ai",
    "execution": "896f42b8-2ed4-48a2-8860-df8678f6d64a",
    "module": "http.call"
  },
  "_fatal": null
}

 

 

Applies To
  • Okta Workflows
  • Google Drive Create Transfer Request card
  • Google Calendar Create Transfer Request card
Cause

The Data transfer already in progress for the user error can occur when both the Google Drive and Google Calendar Create Transfer Request cards are used to initiate a transfer request for the same user in close succession. Google allows only one data transfer request at a time to be in progress for a given user, regardless of the application being transferred. The first transfer request must be complete before another transfer request can be successfully initiated.

Solution

Depending on the amount of data being transferred, a transfer request can take seconds, several hours, or longer. Adding a Wait For card between the Calendar and Drive Create Transfer Request cards to wait for 5-10 minutes may help avoid the 409 Conflict error. 

If transfers take hours or longer, it is recommended that user information be offboarded to an external source so the second transfer request can be processed later using a scheduled workflow. When a Create Transfer Request card executes successfully, it returns the Transfer ID and Transfer Status as outputs. The Transfer ID can also be offboarded and used in the scheduled workflow with the Read Transfer Request card to check the status of the first transfer request, before initiating the second request. If the transfer is complete, a status of completed will be returned. If the transfer is still in progress, a status of inProgress will be returned. 

Creating a solution that uses a scheduled workflow will depend on the specific use case, including other offboarding requirements, and is out of scope for this article.

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"409 Conflict" Error when Using the Google Create Transfer Request Cards in Workflows