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''404 Page Not Found'' Error when Logging Out of the MuleSoft Anypoint Platform

Single Sign-On
Okta Classic Engine

Overview

When admins set up the MuleSoft Anypoint Platform app from the Okta Integration Network (OIN), Single Logout does not work and results in the following error upon logging out from the platform portal:

404 Page Not Found


Applies To

  • Security Assertion Markup Language (SAML)
  • MuleSoft Anypoint
  • Okta Classic Engine

Cause

The wrong Single Logout (SLO) URL is specified in the SAML profile settings. 
 

Solution

  1. Access the MuleSoft admin portal.
  2. Navigate to Access Management.

Access Management Menu

  1. Locate the SAML settings and click Edit.
  2. Locate the SLO (Single Logout) field, type the full org name without any IDs, and save (for example, https://mycompany.okta.com).
  3. Validate the log-out flow. It should now log users out and redirect them to the Okta dashboard.

 

Related References

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Okta Support - ''404 Page Not Found'' Error when Logging Out of the MuleSoft Anypoint Platform