Okta adminstration with the Application Admin role Skip to main content
https://support.okta.com/help/answers?id=906f0000000blu7iai&refurl=http%3a%2f%2fsupport.okta.com%2fhelp%2fanswers
How satisfied are you with the Okta Help Center?
Thank you for your feedback!
How satisfied are you with the Okta Help Center?
1
2
3
4
5
Very Dissatisfied
Very satisfied
Enter content less than 200 characters.
Ask Search:
Patrick CesardPatrick Cesard 

Okta adminstration with the Application Admin role

Hello.

Has anyone tried to set up an Okta adminstration with the Application Admin role, and selected a specific app? It seems I cannot select a custom SAML application I have.
Eric KnittelEric Knittel (Okta, Inc.)
I suspect you created this application using the SAML Template app?  If you are using the SAML template application, then you need to assign the template to the admin.  This is not ideal as it allows them to administer all SAML template apps.  I recommend using the Application Wizard (Green Button) for your SAML applications.  You can then reference them by name for application administrators.

Eric Knittel, Regional Director, Professional Services, Okta
Phil IbarrolaPhil Ibarrola
Hi Patrick,

I have found granting admin privileges for apps created with SAML templates requires you to grant admin privileges to ALL applications created with that template.

So in your scenario, you would grant admin privileges to the Template SAML 2.0 App.  Unfortunately, this user would then be granted admin privileges to any apps in your org which was created with that template.

What we have done to get around this is to create all our apps using the "Create a New App" option when adding them to Okta.  This allows you to have better control over admin privileges.  The only down side was passing group attributes from Okta to custom created apps wasn't possible (we use groups to enforce authorization within the application).  However, I believe this limitation is gone (or will be soon).

Thanks,
Phil
 
Patrick CesardPatrick Cesard
Thx Eric and Phil. I tried the Application Wizard or the "Create a New App" option as you suggested, and it does give me similar SAML 2.0 integration forms seen with in the Template SAML 2.0 App, which should help solve my issue.