Making use of SSL certificate on IWA server used for Desktop SSO Skip to main content
https://support.okta.com/help/answers?id=906f0000000xzkviao&refurl=http%3a%2f%2fsupport.okta.com%2fhelp%2fanswers
How satisfied are you with the Okta Help Center?
Thank you for your feedback!
How satisfied are you with the Okta Help Center?
1
2
3
4
5
Very Dissatisfied
Very satisfied
Enter content less than 200 characters.
Ask Search:
ANGELA BIRDANGELA BIRD 

Making use of SSL certificate on IWA server used for Desktop SSO

Hi all

I have configured IWA within our environment on IIS 7.5 and am having some issues with trying to get IIS to use port 443. If I configure the URL within my Desktop SSO page in OKTA to be an HTTP url and not a HTTPS url, all works fine when accessing the OKTA URL (i.e. I do get signed in automatically) barring getting a warning that I am not making use of a secure connection. Obviously to make use of a secure connection it would mean changing this to an HTTPS url.

Though, if I try and use HTTPS I can't seem to get SSO working at all. Is there any documentation which walks you through configuring SSO with a third party trusted cert on IIS? Is a third party trusted cert required to be installed on IIS? Can someone possibly advise me best practice on this?

Many thanks
Angela Bird
Leendert NoordzijLeendert Noordzij (Okta, Inc.)
Hello Angela,

Here some fairly straightforward MS documentation which I have passed on to several customers with good results..

http://www.iis.net/learn/manage/configuring-security/how-to-set-up-ssl-on-iis

Hope that helps,let us know how you get on.

Leendert Noordzij, Sr. Technical Support Engineer, Okta