Erro changing from ADFS to Okta SSO in Office 365 Skip to main content
https://support.okta.com/help/answers?id=906f0000000i00hiac&refurl=http%3a%2f%2fsupport.okta.com%2fhelp%2fanswers
How satisfied are you with the Okta Help Center?
Thank you for your feedback!
How satisfied are you with the Okta Help Center?
1
2
3
4
5
Very Dissatisfied
Very satisfied
Enter content less than 200 characters.
Ask Search:
Ben SnapeBen Snape 

Erro changing from ADFS to Okta SSO in Office 365

Hi,

this morning I changed my Office 365 domain to authenticate with Okta using the Set-MsolDomainFederationSettings provided in the setup guide.
When clicking the Okta chicklet for Office 365 I could log in succesfully, if I went to https://portal.office.com I was still redireted to the ADFS page https://sts.domain.com and the login failed when I entered my credentials.
I waited about 30 minutes in case the settings had to update throughout the server before swapping the setings back to adfs.

Does anyone know the reason the update failed to work fully on the tenant?

This is the only federated domain on my tenant.

Cheers
Ben
 
Best Answer chosen by Ben Snape
Raja NejemRaja Nejem (Okta, Inc.)
Hello Ben, one of my customers experienced a similar issue.  It seems there is a major delay on the Office 365 side.  Did you check to see if it was working today?  
After we federated with O365, we can log in through the Okta portal, but it took about an hour for the redirect to work when going to portal.office.com.  

All Answers

Kevin TurnerKevin Turner (Okta, Inc.)
Hi Ben

On the generated instruction set, there are two powershell commands that would be shown. Which one of the two did you use?
Kevin TurnerKevin Turner (Okta, Inc.)
You would need to use the lower one of the two options.
Ben SnapeBen Snape
Hi Kevin,

Thanks for your help, I was using the second powershell command to update an already federated domain.

Cheers
Ben
 
Raja NejemRaja Nejem (Okta, Inc.)
Hello Ben, one of my customers experienced a similar issue.  It seems there is a major delay on the Office 365 side.  Did you check to see if it was working today?  
After we federated with O365, we can log in through the Okta portal, but it took about an hour for the redirect to work when going to portal.office.com.  
This was selected as the best answer
Ben SnapeBen Snape
Hi Raja,  took about an hour but it did update eventually.

Thanks for your help