I have created a test login in Okta to get sample Okta token. I have also created a test API client using that sample Okta Token. But when I tried to hit the API to GET or POST some data, I am getting “Invalid Token Provided” error. Any idea on this? Skip to main content
https://support.okta.com/help/answers?id=906f0000000dfkriao&refurl=http%3a%2f%2fsupport.okta.com%2fhelp%2fanswers
How satisfied are you with the Okta Help Center?
Thank you for your feedback!
How satisfied are you with the Okta Help Center?
1
2
3
4
5
Very Dissatisfied
Very satisfied
Enter content less than 200 characters.
Ask Search:
Anusree UAnusree U 

I have created a test login in Okta to get sample Okta token. I have also created a test API client using that sample Okta Token. But when I tried to hit the API to GET or POST some data, I am getting “Invalid Token Provided” error. Any idea on this?

Gabriel SrokaGabriel Sroka (Okta, Inc.)
Hi Anusree
Are you providing the token using the SSWS Authorization header? Can you provide some of your sample code? (you can omit your actual token)

Also, did you check out these instructions or try Postman (a test client) ?
http://developer.okta.com/docs/api/getting_started/api_test_client.html
Anusree UAnusree U
Hi Gabriel.

Yes, i am using SSWS Authorization header and i am testing it using Postman API client with the instructions given in the same link that you have mentioned above. And i dont have "Open ID Connection" enabled in my Okta developer account where i have created my Okta API token and App. Is that the porblem?
Gabriel SrokaGabriel Sroka (Okta, Inc.)
Hi Anusree

>provide some sample code
In what language? I'm not sure what you're trying to do. Can you explain which API(s) you're calling? Also, can you post your steps (without your token)?

>I don't have "OpenID Connect" enabled
I'm not sure what that would have to do with it. Are you using OpenID? Or is this a simple API call?