Error when provisioning new users to Salesforce app Skip to main content
https://support.okta.com/help/answers?id=9062a000000bmlbqai&refurl=http%3a%2f%2fsupport.okta.com%2fhelp%2fanswers
How satisfied are you with the Okta Help Center?
Thank you for your feedback!
How satisfied are you with the Okta Help Center?
1
2
3
4
5
Very Dissatisfied
Very satisfied
Enter content less than 200 characters.
Ask Search:
Katie EvansKatie Evans 

Error when provisioning new users to Salesforce app

We are seeing an error when provisioning new users to a Salesforce app. 

"An error occurred while assigning this app.
Automatic provisioning of user Katie TEST Evans to app Salesforce.com failed: Matching user not found"

We have never seen this error before. We have tried editing the app assignment and retrying but still receive the error.

What does this mean and how can we resolve it?
Marc JohnstonMarc Johnston (Okta, Inc.)
Hi Katie,

You see the message 'Matching user not found' when the username does not match between the Okta app assigment and the Salesforce user. Verify that your provisioning credentials for Salesforce are valid by Testing the API Credentials. This provisoining message can be resolved by the steps below:
  • Edit the task on the dashboard. Make sure the Username and attributes match the user on the Salesforce side.
  • If this is a new Salesforce user, enable the Create Users settings under Provisining for the app within Okta.
  • If this is an existing user, enable Update User Attributes under Provisining for the app within Okta. (Warning: This option will make Okta the profile master and update all information in Salesforce for that user.)