Redirect not always working Skip to main content
https://support.okta.com/help/answers?id=9062a000000xalpqak&refurl=http%3a%2f%2fsupport.okta.com%2fhelp%2fanswers
How satisfied are you with the Okta Help Center?
Thank you for your feedback!
How satisfied are you with the Okta Help Center?
1
2
3
4
5
Very Dissatisfied
Very satisfied
Enter content less than 200 characters.
Ask Search:
Derek YagerDerek Yager 

Redirect not always working

Hello, I have a client where sometimes the redirect is working and sometimes not.

They go to https://client.okta.com/app/UserHome

 

When they click on the servicenow option, it takes them to the instance liek they should the first time, then  if a user navigates back to the login page and clicks it again, it shows a service portal redirect instead, which says  click here to return to SP, but it  takes them to an about page.

 

Any ideas on what is causing this? it has happened with multiple users

Cristian MondiruCristian Mondiru (Okta, Inc.)
Hello Derek,


  Thank you for reaching out to Okta Support! If there were no changes made to the application setup, the behavior requires further investigation. W would recommend performing SAML traces while reproducing the behavior and another trace for the non-affected flow and open up a support ticket, on which the traces will be attached.


Thank you,
Cristian Mondiru
Technical Support Engineer
 
Dylann FezeuDylann Fezeu (Customer First Programs)
Hello,

Thanks for posting your inquiry in Okta Community Portal.

If you receive a great answer to your question(s), please help readers find it by marking it the best answer. Hover over the answer and click "Best Answer." 

Thank you,

Dylann Fezeu
Okta Help Center Team
Derek YagerDerek Yager
Can you explain what you mean by the saml trace? Is this from the SN instance or from the internal side or?