Office 365 Teams external (guest) access issue Skip to main content
https://support.okta.com/help/answers?id=9062a000000quvnqak&refurl=http%3a%2f%2fsupport.okta.com%2fhelp%2fanswers
How satisfied are you with the Okta Help Center?
Thank you for your feedback!
How satisfied are you with the Okta Help Center?
1
2
3
4
5
Very Dissatisfied
Very satisfied
Enter content less than 200 characters.
Ask Search:
Christoph MülderChristoph Mülder 

Office 365 Teams external (guest) access issue

Hi
we have an issue with external (guest) access to office 365 teams.
I have on tenant A using standard Office 365 authentication. I create a team there and invite two users from tenant B which is using Okta for authentication B1 having a Okta federated account, B2 having a standard Office 365 account. I also invite a user from tenant C which is using standard Office 365 authentication.

C user opens Microsoft Teams application and signs in. He accesses his mailbox, finds the invite to the team from tenant A, opens it. Teams is opened and switches to the data from tenant A

B1 user opens Teams. He accesses the mailbox, and opens the invite to the team. 
Teams askes "Do you want to swith the tenant"? Some seconds later there is a message "something went wrong. Please sign out and in again". teams is restarted, login prompt is presented and I am back in the Teams application within the B tenant .

B2 user opens Team. He acceses his mailbox and open the invite to the team. Teams asks "do you want to switch the teantn? He is logged off from Teams application and a new login window opens "login to Microsoft Teams, "operated by Okta" in the lower left corner. He can of course not use his Office 365 account to login here. 
I tried to disable IWA and also tried from outside the office but the issue remains the same.
Thanks for help
Christoph
Alexandru MoraruAlexandru Moraru (Okta, Inc.)
Hi  Christoph,
Thank you for reaching out to Okta
Currently the behavior you experience (No external access to the Teams workspace) seems to be a known issue according to the last update on the Known issues for Microsoft Teams (https://docs.microsoft.com/en-us/microsoftteams/known-issues) article.
Best regards.
Christoph MülderChristoph Mülder
Hi Alexandru,
thanks for response.
Yes, there is an issue with general access. It is not so easy to get it running. But it works - without Okta. So there seems to be some special issue with the Okta auth in Teams.
Christoph