Assign SWA password to a group Skip to main content
https://support.okta.com/help/answers?id=9062a000000quleqa0&refurl=http%3a%2f%2fsupport.okta.com%2fhelp%2fanswers
How satisfied are you with the Okta Help Center?
Thank you for your feedback!
How satisfied are you with the Okta Help Center?
1
2
3
4
5
Very Dissatisfied
Very satisfied
Enter content less than 200 characters.
Ask Search:
S RollandS Rolland 

Assign SWA password to a group

We want to assign a SWA app to about 100 users, they will all have the same password but will not be given it as we'd like to change it centrally in the OKTA interface. We have created the group and added the users but now need to assign that password to all of those users in a batch. We do not use AD or pull from any other directory service so this has to be done solely with OKTA. Is this possible?
Paul AuerPaul Auer (Okta, Inc.)
Thank you for contacting Okta Support.

There are two ways to do what you want, but neither of them is exactly what you are looking for. You can either make the users to share a single username and password, both of them set by you (from your Admin Console -> Applications -> the app in question -> Sign On -> Secure Web Authentication -> Users share a single username and password set by administrator) or you can choose, from the same place, Administrator sets username and passoword; with this option you have to go to every user profile (under the Assignments tab), hit Edit and set the password manually.

Thank you,
Paul Auer
Technical Support Engineer | Okta
Adam MurphyAdam Murphy
This is not a great answer to the original question, which I also have.  How can be have each user have their own login, with the password set by the admin?  Having to go into each individual profile is unrealistic at any sort of scale (we have thousands), and we don't want them to all have the same username as that will not work for the app.  It would be great if that option allowed us to set a variable for the username (something like ${user.email}  ), but unfortunately that does not seem to work.  Is there a way that i'm missing?