How do I get the AD Sync Agent to sync changes to OU names? Skip to main content
https://support.okta.com/help/answers?id=9062a000000dfpsqa4&refurl=http%3a%2f%2fsupport.okta.com%2fhelp%2fanswers
How satisfied are you with the Okta Help Center?
Thank you for your feedback!
How satisfied are you with the Okta Help Center?
1
2
3
4
5
Very Dissatisfied
Very satisfied
Enter content less than 200 characters.
Ask Search:
Jeff SaniJeff Sani 

How do I get the AD Sync Agent to sync changes to OU names?

I have installed the Okta Sync Agent, but the OU list is incomplete.  Since installing I added more OUs but they are not refelcted in the list on the site.  Also, I tried to chagne the name of an OU and it did not update.  I set my sync interval to the lowest.  Even tried to remove and reinstall but got the same results. :-S
Best Answer chosen by Jeff Sani
Cody SudersCody Suders (Okta, Inc.)
If you go into the active directory import tab and hit "Import Now" it'll prompt you for an incremental or full import.  A full import should refresh the OU list.  If this doesn't resolve the issue please contact Okta support for assistance. 

All Answers

Cody SudersCody Suders (Okta, Inc.)
If you go into the active directory import tab and hit "Import Now" it'll prompt you for an incremental or full import.  A full import should refresh the OU list.  If this doesn't resolve the issue please contact Okta support for assistance. 
This was selected as the best answer
Jeff SaniJeff Sani
so sync is workign now - thx, but the users in my OU are not importing...I tried creating an Okta user first and slecting to match that but no dice.
Kevin TurnerKevin Turner (Okta, Inc.)
Hi Jeff

Can you make sure that you're AD users have as a minumum a firstname, lastname and a valid username. Okta requires a minimum of four profile attributes to create the users with. The following are required firstname, lastname, username (in the format of an email address), and an email address (that we can dynamilcally create if one has not been set in AD). Additionally make sure you have a selected OU where the users are placed in the AD tree structure as well.

Hope this helps, if not then look to the AD log to see for any obvious reasons. (Default location for logs is C:\Program Files (x86)\Okta\Okta AD Agent\logs)