Okta integration with F5 Skip to main content
https://support.okta.com/help/answers?id=9062a000000dfoyqao&refurl=http%3a%2f%2fsupport.okta.com%2fhelp%2fanswers
How satisfied are you with the Okta Help Center?
Thank you for your feedback!
How satisfied are you with the Okta Help Center?
1
2
3
4
5
Very Dissatisfied
Very satisfied
Enter content less than 200 characters.
Ask Search:
Vikash DayaVikash Daya 

Okta integration with F5

Hi

I'm trying to integrate F5 with Okta following the guide provided by Okta.  I can't seem to get this to work.  My scenario is as follows:-

I have on on-premise legacy application (Dynamics CRM 4.0) that sits behind the F5's.  Users authenticate with their AD credentials.  I've setup the AD Agent in Okta and Synced the accounts (profile mastered in AD).  I test the delegated authentication and it's successful.  I've also setup the application in Okta (as per guide) with a rule to use MFA at each login.
F5 has BigIP as SP service configured with IDP from metadata.xml.  Access profile has been setup using SAML Auth and then associated to the Virtual Server.  

Here's what happens...

I go to the URL and get redirected to Okta sign-in page;
I sign-in successfully with MFA, but when redirected to my application URL, it goes into a loop (back and forth between the two) - then stops at Okta MFA page.

I complete the MFA again and it loops again and comes right back there.  The loops repeat roughly 6-10 times.

Any help would be much appreciated.


Thanks 
Kevin TurnerKevin Turner (Okta, Inc.)
Hi Vikash, this still sounds like a configuration issue. If it's not resolved, you might like to file a support ticket on this one. You can do this via you Okta Admin Console, by going to the "Support & Training" link, and then select the option in the top right hand corner to "Open a Case".