User has been setup with API but when logged into okta portal shows again setup page to select profile pic and security question Skip to main content
https://support.okta.com/help/answers?id=9060z000000jjjhqac&refurl=http%3a%2f%2fsupport.okta.com%2fhelp%2fanswers
How satisfied are you with the Okta Help Center?
Thank you for your feedback!
How satisfied are you with the Okta Help Center?
1
2
3
4
5
Very Dissatisfied
Very satisfied
Enter content less than 200 characters.
Ask Search:
khaleel Akhaleel A 

User has been setup with API but when logged into okta portal shows again setup page to select profile pic and security question

User has been setup using API with security question, password, phone number alreasy been setup. But when user tried to logging to okta portal it shows a setup screen with option to add security question and select profile pic. How to avoid this screen and directly go to landing page of portal? Is it like we need to add a default profile pic thru API also? will this solve the issue ?
Paul StinigutaPaul Stiniguta (Okta, Inc.)
Hello Khaleel,

In order to bypass that screen is to create a security question for the suer as well. The welcome screen appears when the user does not have one and he needs to set it up.
You can use Create Activated User with Password & Recovery Question API call. 
For user creation you can use this documentation https://developer.okta.com/docs/api/resources/users

Paul Stiniguta
Technical Support Engineer
Okta Global Customer Care
khaleel Akhaleel A
Yeah with the API we created user with security question. even though it shows up. Is it something to do with the profile pic?