Forgot Password Widget does not work if it is not at the "Root of the Domain" Skip to main content
https://support.okta.com/help/answers?id=9060z000000jjg9qac&refurl=http%3a%2f%2fsupport.okta.com%2fhelp%2fanswers
How satisfied are you with the Okta Help Center?
Thank you for your feedback!
How satisfied are you with the Okta Help Center?
1
2
3
4
5
Very Dissatisfied
Very satisfied
Enter content less than 200 characters.
Ask Search:
Mark RossMark Ross 

Forgot Password Widget does not work if it is not at the "Root of the Domain"

We have a custom link to “/subdirectory/signin/forgot-password”.  We use the Angular’s routing to route to that URL because we only want to show one link there.  This all works when the widget is at the root of the domain.  Any workarounds ?
Paul AuerPaul Auer (Okta, Inc.)
Thank you for reaching out to Okta Support.

Based on the information you have provided us with, I believe that you are trying to use a deep link with the Sign-In Widget which, unfortunately, is not currently supported. Anyhow, if you'd like us to further investigate into this issue, please open a Support case.

Thank you,
Paul Auer
Technical Support Engineer | Okta
CPS Okta AdminCPS Okta Admin
Paul,

Appreciate the response and we have opened a support case.  Here is the ticket number: 00412639.  If you do not support deep links, how do you work around the issue?  Seems that this would be pretty common practice that sites would be built with multiple directory levels.  Any examples how others customers have worked around?