Why do I keep seeing MFA prompts? Skip to main content
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Why do I keep seeing MFA prompts?
Published: Nov 3, 2017   -   Updated: Jun 22, 2018
Issue: I continue to see MFA prompts after selecting "Do not challenge me on this device again". Why?

Applies to: 
  • All Okta environments
  • All browsers
  • All devices

Cause: 
  • Possible causes include:
    • Cookie management
    • Policy configuration
    • Exempted action

Resolution: 

This is an issue with multiple potential causes and potential resolution paths. 
  • Cookie management
    • The 'Do not challenge me again...' choice is captured in a browser cookie. Therefore anything that removes cookies or restricts/disrupts their creation could lead to being re-prompted unexpectedly. Similarly, using an alternate browser will re-prompt
  • Policy configuration
    • Okta Policies can be targeted differently depending on Group membership, physical location and a variety of other criteria. It's possible that the anticipated behavior is being superceded by one of these criteria or a higher level policy. 
  • Exempted action
    • Certain actions like editing your account profile will reprompt DESPITE choosing 'Do not challenge me....' as an additional layer of security.